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This tutorial was developed to take budget staff through the sequential steps of building a budget using 
the Budget Development System (BDS).   
 
This tutorial can be used in a formal training session, for individual practice, or developing the agency 
budget request. Actual values to be entered when using for training or for practice are highlighted. If 
practicing on your own, please use your judgment to determine values to be used for practice or actual 
budget work. Each task is preceded by a brief explanation of the task and its importance in your budget 
development, as well as general business rules. Specific business rules and recommendations for 
entering your budget are denoted with a  on the task. Please note when using for budget 
development, use the appropriate biennium, budget source and budget type.  These depend on the time 
of year and activity being performed. 
 
Every effort is made to ensure that the BDS tutorial and OFM Budget Instructions agree in every way.  
In case there is a discrepancy, the OFM Budget Instructions take precedence. The OFM Budget 
Instructions can be found at http://www.ofm.wa.gov/budget/instructions/operating.asp . 
 
The BDS Tutorial is available to users available online in the Budget Portfolio Systems (BPS) Library 
at https://budgetlogon.ofm.wa.gov/library/default.htm 
 
The library may also be accessed by the help links available in all BPS applications. 
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BDS Goals 
 
BDS is designed to support those budget development activities that are common to most agencies. 
These include: 
 
Building Your Budget Base – The version base is the Current Biennium Expenditure Authority and is 
displayed as the first line of the Recommendation Summary Report. Agencies are required to Recast 
budget data by activity and submit to OFM once a budget is enacted. The data in the Enacted Recast 
version should be the same in total as the current Expenditure Authority. The previous biennium’s 
recast is now the foundation for the next budget.  
 
Creating Preliminary Budget Proposals – Users can easily build proposed decision packages in BDS at 
a summary level, entering a description and justification, and funding estimates at the agency or 
program level. As the package moves through the agency's budget approval process, more detail can be 
added to the package using the same system features. 
 
Recording all Elements and Impacts in the Decision Packages - Users can enter a variety of budget 
elements into each decision package. BDS allows users to input decision package narrative and 
justification under a standard set of headings outlined in the budget instructions. It allows you to link 
the decision package to your agency's strategic plan through goals and performance measures. It 
provides budget worksheets to record estimated expenditures by fund, expenditures by object, FTE, 
revenue, and performance measure impact.  
 
Customized Decision Package Worksheets - BDS gives each agency the flexibility to build each of 
their decision package worksheets at the level needed to meet their organizational budgeting and 
reporting needs. Decision Packages include the same program, organization, and project index 
structure used in AFRS, as well as budget unit, and agency activity. Each decision package can carry 
its own worksheet coding, and the coding built in one package can easily be copied to another.    
 
Identifying Incremental Budget Changes - BDS supports the creation of the agency budget following 
the standards defined in the overall state budget step table. In entering data for the four steps, (current 
biennium-CB, carry-forward level-CL, maintenance level-ML, and performance level-PL) users can 
create decision packages that focus on either mandatory or optional budget adjustments. Several BDS 
reports follow the step table format and provide a bottom line view of the budget.  
 
Looking at the Big Picture - BDS provides online summarized views of your budget. The list of 
decision packages by ID gives users a real time indication of the scope and size of your budget. The 
associated decision package filter option allows users to focus in on specific budget elements. The list 
of decision packages by ID view allows users to drill into any of the packages on the list.  
 
Creating Multiple Budget Scenarios - Agencies can build different budget scenarios using the version 
feature in BDS. Agencies can define, create, and assign budget versions as needed to organize their 
budgets and group related decision packages. A version can contain one or more budget levels 
(CB,CL,ML,PL). The use and assignment of a version is not restricted in any way.  
 
Preparing Your Budget Submittal - As the agency begins to reach final decisions on the agency budget, 
you may want to limit edit access to your budget. Users can lock a decision package, or (in the future) 
an entire version. This allows authorized staff to make last minute adjustments prior to your release to 
OFM. BDS will automatically roll up the budget data to the level required by OFM for submittal 
budget reports and electronic release. 
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Budget Reporting - BDS offers a series of working reports at the detail and summary levels, as well as 
a set of submittal reports required by OFM. A new reporting feature allows users to download the 
report to Word or Excel for further formatting or preparation of your final budget document.  More 
detailed and flexible reports are available through the Budget Reporting System – BDS reports tab. 
 
Develop the Agency Activity Inventory – BDS now offers Activity Descriptions, performance measure 
descriptions and estimated amounts, and ties to incremental decision packages for development of the 
agency budget and activity inventory as one seamless exercise.  
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Getting Started – Logging on to BDS and System Navigation 
 
1. Open Internet Explorer and enter the login address https://budgetlogon.ofm.wa.gov/Logon.aspx in 

the address bar of the browser.  
If in a training session, skip this step 

 
2. Use your login ID and password to log in to BPS.  If you do not have a login ID and password, a 

security form is located in the BPS Library.  https://budgetlogon.ofm.wa.gov/library/security.pdf  
 

3. Before going into BDS ensure that your Internet Explorer settings are as shown below: 
a. Select Tools Menu 
b. Select Compatibility View Settings 
c. Type wa.gov in the “Add this website” and click add if it is not listed in the box 

labeled “Websites you’ve added to Compatibility View” 
d. Click Close 
e. Ensure that Pop-Up Blocker is turned off by going back to the Tools Menu  

 
4. Select the calculator icon for Budget Development System (BDS). 

 Note: Some menu options will be grayed out if a user with "Edit Access" only rights.  See 
your agency budget officer if you need to complete tasks not currently available to you. 
 

 
 

 Note: If you get a small grey box instead of the main menu please contact WaTech Solution Center 
solutionscenter@watech.wa.gov or 360-407-9100, BDS may need to be reinstalled on your computer. 
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The BDS Menu is designed to lead an agency through the steps in building their budget from the 
creation of their budget base, to preparing your agency budget proposal for submittal to OFM.  
 
The BDS menu consists of the following selections: 
 

 
 

 
1. Load my agency budget base (AFRS Extract) – Allows the agency budget operations staff to 
extract current biennium data from AFRS (official or adjusted allotments with or without expenditures 
through the previous month close), and load into the BPS budget database. Brings up the AFRS Extract 
Screen. 
 
2. Adjust my agency budget base (View/Edit CB level packages) – Allows the user to view and/or 
update current biennium decision packages (Budget Level CB). Brings up List Decision Packages by 
ID screen and sets the DP filter to view only current biennium decision packages.   
 
3. Add decision package to my base – Allows the user to add a decision package to any budget level 
in the statewide budget step table. Brings up the Add a Decision Package screen. 
 
4. Update decision packages - Displays a list of decision packages available to the user, and allows 
the user to open a decision package for update.  Brings up List Decision Packages by ID screen.  
 
5. Re-prioritize my agency’s decision packages - Allows the agency budget operations staff to 
prioritize decision packages. Brings up the Prioritize Decision Package screen within the Decision 
Package Management Tab Set of the Budget Management Console.  Not available to Edit Access 
users. 
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6. Lock a decision package - Allows the agency budget operations staff to lock a decision package. 
Brings up the Decision Package Control tab within Decision Package Management Tab Set of the 
Budget Management Console.  Not available to Edit Access users. 
 
7. Lock a budget version - Allows the agency budget operations staff to lock a version. Brings up the 
Add/Update Version screen within the Version Management Tab Set of the Budget Management 
Console.  Not available to Edit Access users. 
 
8. Other budget management options - Allows the agency budget operations staff to perform 
administrative functions.  Brings up a list of all of the functions available in the Budget Management 
Console. They include the ability to lock or delete decision packages, prioritize decision packages, 
modify the agency decision package titles, version management functions, titles management, and 
AFRS extract.  Not available to Edit Access users (except Working Capital Reserve). 

 
9. Verify data to be released to OFM - BDS will check to verify that certain data is in order prior to 
allowing you to release your budget.  See Appendix 1 for Pre-Release Edits 
 
10. Exit to Main Menu – Exits to the BPS Menu. 
 
11. Exit and Logoff – Exits and logs out of BPS. 
 
12. BDS Help – Takes user to the BPS help library.  
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Lesson 1, Task 1 – Establish a BDS version and set Default DP Filter 
 
Prior to entering a new budget into BDS, a new version will need to be established. This lesson will: 

 Take the user through entering the new Version with the budget type and budget source  
 Set the agency Default DP Filter  

 
1. From the BDS Menu select: 

 Other Budget Management Options > Version Management > Add/Update Version   
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2. Select the Budget Period  
 2017-19 

 
3. In the empty row enter any two-digit code in the Version cell (numbers and/or letters in any order) 

to distinguish this version then hit the Tab key.   
 <Your initials> 

 Note: Version Coding is at the agencies discretion; the same coding structure can be used across 
bienniums. 
 
4. Assign a Title to your version and hit the Tab key 

 <Your Name> Chosen Title 
 

5. Select ‘Agency’ from the list of Budget Sources 
  

  Note: You will choose Agency for an agency request version or Enacted for an enacted budget 
version. 

 
6. Select ‘Regular’ from the list of Budget Types and hit the Tab key.  You should now see the 

version you just added in blue font  
 

 Note: You will choose ‘Regular’ Budget Type for the Biennial Budget. Select First Year 
Supplemental or Second Year Supplemental for your Supplemental Budget requests. 

 
7. Hit the Save button to save the Version. 
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8. Select the Set Default DP Filters tab, setting the agency Default DP Filter assures that users 
new to BDS will default to the indicated version.   
 

9. Choose the Budget Period   
 2017-19 

 
10. Choose the Version  

 <Your Initials> - <Your Name> Practice 
 

11. Ensure Package Program is listed as ‘Agency Level’ 
 

12. Leave Budget Level on the default of ‘All’ 
 

13. Leave the View locked decision packages only unchecked, or change if necessary 
 

14. Click the Save button 
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IMPORTANT: You will need to update your filter in Decision Package Management to ensure you 
are adding Decision Packages to the correct Version.  
 

1. From Decision Package Management – Select File > Change Version / DP Filter 
 

 
 

2. Select the Budget Period, Version, Package Program, and Budget Level 
3. Select OK 

 
 

4. Confirm the Version you are working in by looking at the bottom of the console 
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Lesson 1, Task 2 – Create the Budget Base 
 

The version base is the Current Biennium Expenditure Authority and is displayed as the first line of the 
Recommendation Summary Report. Agencies are required to Recast budget data by activity and 
submit to OFM once a budget is enacted. The data in the Enacted Recast version should be the same in 
total as the current Expenditure Authority. The previous biennium’s recast is now the foundation for 
the next budget.  
 
The supplemental budget request only requires the changes you are requesting.  For this reason it is not 
necessary to create a current biennium extract and/or decision package. If you do create a current 
biennium (CB) package that data will not be received by OFM; for Supplemental Budgets.  Please 
refer to the OFM Supplemental Budget Instructions for required documentation. Skip to Lesson 3 if 
working on Supplemental Budget Request. 
 
This task will show you how to create your Version Base by copying the Enacted Recast Version to 
the ensuing biennium budget request. 
 
 

1. From the BDS Menu select: 
 Other Budget Management Options > Version Management > Create Version Base 
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2. Select the previous budget period in the Copy From: Budget Period 
 2015-17 

 
3. Select the Version 

 EN – Enacted Recast  
 

4. Select the ensuing biennium for the Copy To Budget Period 
 2017-19 

 
5. Select the version created in Task 1 for the Copy To Version 

 <Your Initials> - <Your Name> Practice 
 
6. Leave Replace existing CB-00 Decision Package expenditure data unchecked 
 
7. Click Copy 

 

 
 
8. Select Yes and then OK to the confirmation messages 
 
9. Select File > Exit to BDS Menu  
 

 
RESULTS* You have created a version base for your ensuing biennium budget.  We will verify and 
make any needed corrections to the base when verifying carry-forward level in the next lesson. 
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Lesson 2, Task 1 – Carry-forward Decision Package  
 

The carry-forward level is a reference point created by calculating the biennialized cost of decisions 
already recognized in appropriations by the Legislature. Carry-forward decision packages are the next 
incremental layer added to the current biennium base. OFM calculates the carry-forward level for each 
agency and provides agencies with a worksheet indicating the amount by fund that will be placed in 
budget submittals.  
These ensuing biennium revisions generally match legislative assumptions of "bow wave." See the 
OFM budget instructions for a more detailed description.  Once OFM has determined the carry-
forward amounts, agencies can go to VRS, select the CF version and run a report to view their carry-
forward level. 
Carry-forward decision packages prepared in BDS will not be released to OFM; OFM will use its 
calculated carry-forward level as the base data. However, OFM and Legislative staff do use the 
Recommendation Summary reports provided by the agency in its budget submittal--these reports must 
show the OFM approved carry-forward level or OFM will ask agencies to resubmit correct reports.  
Agencies will not be allowed to release a BDS version when the version carry-forward total does not 
match the official OFM carry-forward level total. The steps described below allow users to record their 
carry-forward adjustments in BDS to ensure that BDS reports ran by the agency reflect the OFM carry-
forward level. 
 
There are two options for entering decision packages for adjusting carry-forward level.  

1. Individual Decision Packages for biennialization of each carry-forward level line item. 
2. One Decision Package that adjusts for the total amount of the carry-forward level 

adjustment. 
 
This task will walk you through creating individual decision packages. 
 

1. From the Create Version Base screen you can select File > Add a decision package 
 

 



Page 18 of 86 
 

 
2. Select the Budget Period  

 2017-19 
 

3. Select the Version  
 <Your initials> - <Your name> Practice 

 
4. Select the Budget Level: CL – Carry-Forward Level  

 
5. Select an available Decision Package Code  

 
6. Leave the Package Program as the default: Agency Level  

 
 Note: Agency level means it can contain any agency program.  Use of a specific package 

program is an advanced feature that is not discussed further in this tutorial.  The use of 
package program is only recommended in rare cases, such as DSHS budget building. 

 
7. Give the Decision Package a Title 

 Biennialization of Field Office X  
 

8. Leave the Package Long Title blank  
 

9. Check the Open this decision package after Save. Decision package filter will be modified.  
 

 Note: Clicking this box will open the decision package upon saving; it also updates your 
BDS default filter to reflect the budget period, version, and budget level you have selected. 
 

10. Click ‘Save’, and select ‘Yes’ and ‘OK’ for the following two messages   
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The Decision Package Console will open: 
 

1. Click on the Affected Pgms/Subpgms/Budget Unit/Activities tab  
 

2. Double click on Agency Level in Affected Programs/Subprograms/Budget Units/Activities 
list to move it out of the Affected Programs/Subprograms/Budget Units/Activities 
 

 
 

3. Select the Affected Program > Available Activity and click the > to move this into the 
Affected Programs/Subprograms/Budget Units/Activities. Do this for each Affected 
Program and Activity combination 

 010 – A005 
 010 – A012 
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 Note: Program level detail is only required for agencies that are appropriated at the 
program level, and recommended if your agency has more than one program.  
 

 Note: Available Subprograms and Available Budget Units can be maintained in the Other 
Budget Management Options under Titles Management. The previous box must be selected 
before the next field is enabled. 
 

 Note:  The Affected Programs/Subpgms/Budget Units/Activities tab is the easiest way to 
create column structures in the expenditure worksheets. Assigning activities through this tab 
will allow you to meet the requirement of providing maintenance level totals by activity.   

 
4. Click ‘Save’ and ‘Yes’ 
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5. Select the Fund Detail tab.  Note the column titles mirror the structure you selected in the 

previous steps. 
 

 
 

6. Enter the Fund/Appropriation Type and hit the Tab key    
 0011 

 
 Note: You can also right click and choose from a list. 

 
7. Enter the Fund Estimates  

 
 Program 010 / A005 Program 010 / A012 

1st Fiscal Year 2nd Fiscal Year 1st Fiscal Year 2nd Fiscal Year 
001-1 GF-S 20,000 50,000 10,000 30,000 
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8. Right Click on Fund 996-Z and ‘Delete Row’ 

 
 Note: Fund 996-Z is a placeholder fund only. This fund may be used in the interim for 

budget development, however any dollars must be allocated to real funds and 996-Z must be 
zero before agencies can release data to OFM.  
 

 
 

 
9. Select the Objects of Expenditure Detail tab   
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10. Right Click on the empty cell 

 
11. Select the Object  

 A – Sal&Wag 
 

12. Leave the default values for Sub Object and SubSub Obj 
 

 
 

 
 Note: Sub Objects and SubSubObj can be maintained in the Other Budget Management 

Options under Titles Management. The previous box must be selected before the next field is 
enabled. 
 

  Note:  Carry-Forward Decision Packages do not require data entered at the Object level.  
However, using objects in all steps of your budget development is recommended for additional 
analysis. Your Agency can choose to enter objects at the same level as your allotments. This 
will assist you in developing your biennial allotment control numbers once a budget is enacted. 

 
13. Enter ‘B’ into the empty cell and hit Tab 

 
14. Right Click on Object ‘X’ and ‘Delete Row’ 

 
 Note: Object X is a placeholder only. 
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15. Enter your Object estimates 
 

 Program 010 / A005 Program 010 / A012 
1st Fiscal Year 2nd Fiscal Year 1st Fiscal Year 2nd Fiscal Year 

A – Salaries 16,000 30,000 8,000 20,000 
B – Benefits 4,000 20,000 2,000 10,000 

 
16. Select View > Balance Funds to Objects to verify that the objects entered balance with the 

funds entered. 
 

 
 

17. Click on the FTE Detail tab. 
 

 
 



Page 25 of 86 
 

18.  Enter the Fund/Appropriation Type and hit the Tab key    
 0011 

 
19. Right Click on Fund 996-Z and ‘Delete Row’ 

 
 Note: Fund 996-Z is allowed for non-transportation FTE. However, it is recommended that 

you enter FTEs by what you want to be able to use BDS reports and data for additional 
analyses of FTEs by fund. 

 
20. Enter your FTE estimates 

 
  

 Program 010 / A005 Program 010 / A012 
1st Fiscal Year 2nd Fiscal Year 1st Fiscal Year 2nd Fiscal Year 

001-1 GF-S .5 1.0 .4 .8 
 

21. Select File > Save Current Tab Set 
 

 
 
 
RESULTS* You have now added a decision package requesting funding to cover expenditures 
required to operate 24 months of a new field office as compared to the original 15 months it was 
funded for in the current biennium budget. 
This task stepped you through adding separate decision packages for each carry-forward level 
adjustment. Repeat the previous steps to completing the individual carry-forward packages.  
 *Remember, you can add one single carry forward decision package with the sum of all carry-forward 
level adjustments.  
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Lesson 2, Task 2 – Verify Carry-Forward Level to OFM 
 

Users need to verify that the carry-forward level matches the OFM approved carry-forward level 
before preparing the reports that will be submitted with the budget. Your BDS Version must match 
the OFM approved carry-forward level in order to electronically release your agency budget 
request. 
Once OFM has determined the carry-forward amounts, agencies can go to VRS, select the CF version 
and run a report to view their carry-forward level. BDS also provides an automatic check in its "pre-
release edit" process. Contact your OFM Budget Analyst for further information on your carry-forward 
level if you have questions. 

 
1. Obtain the carry-forward report from VRS  

 
2. Select Update Decision Packages from the BDS menu 

 
3. Ensure you are in the correct version by checking the bottom of the Budget Management 

Console   
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4. Select Reports > OFM Reports > Recommendation Summary report 
 

 
 

5. Select the Program level either ‘Agency Level (All Programs rolled up)’ or ‘All Programs at 
the Program Level’ if your agency is appropriated by program.   
Agency Level (All Programs rolled up) 

 
6. If exporting to Word, Select Check here if you want this formatted for Word, then click OK   
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7. Select the Report Format and click View 

 

 
 
 

 



Page 29 of 86 
 

 
8. Print a copy of the report if desired   

 
9. Compare the report from BDS to the report provided by OFM or through VRS to ensure the 

totals on the Total Carry-Forward Level line matches. 
 

10. If a decision package total is incorrect, click once to highlight the decision package from either 
the List Decision Packages by ID or Decision Package Control screens, then select Edit  > 
Expenditure Detail Amounts to correct amounts.   
Skip this step in training 

 
11. If a decision package is missing, select File > Add a decision package to add this decision 

package to your version.   
Skip this step in training 

 
12. If applicable - When all corrections have been made, repeat steps 4 through 9 to validate 

corrections.   
Skip this step in training 

 
 Note: If it appears a discrepancy is on the part of OFM, contact your OFM Budget Analyst.  

 
13. Select File > Exit to BDS Menu when satisfied with your carry-forward level.   

Assume that all is okay in training 
 
 
RESULTS* Your carry-forward level now matches OFM. You can now begin adding the maintenance 
level and performance level layers of your budget to develop your total agency budget request. 
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Lesson 3, Task 1 – Enter Maintenance Level Decision Packages 
 

Maintenance Level decision packages are the second incremental layer added to the current biennium 
base. Maintenance level reflects the cost of mandatory caseload, enrollment, inflation and other legally 
unavoidable costs not contemplated in the current budget. Expenditure adjustments may be positive or 
negative, depending on expected experience in the ensuing biennium. Agencies will notice that BDS 
splits maintenance level into two levels to indicate different kinds of maintenance level costs. 
Agencies prepare the maintenance level component of the budget submittal. Agencies will notice that 
BDS separates maintenance level into two different levels to indicate different kinds of maintenance 
level costs. Maintenance level 1 ( M1) is reserved for items that must be funded due to mandatory 
caseload or enrollment (e.g. funding related to the number of inmates incarcerated). Costs related to 
inflation and mandatory rate changes are included in BDS as Maintenance Level 2 (M2) items. 
Certain specific ML changes should use the OFM pre-assigned decision package code. Please refer to 
the OFM Budget Instructions for the list of specified codes. OFM pre-assigned numbers all begin with 
9, 8 or 7 and have been pre-named in BDS.  
 

1. Select Add decision package to my base from the BDS menu. 
 

2. Select the Budget Period  
 2017-19 

 
3. Select the Version  

 <Your initials> - <Your name> Practice 
 

4. Select Budget Level:  ‘M2 – Inflation and Other Rate Changes’  
 

5. Select an available Decision Package Code  
 <AF>  

 
6. Leave the Package Program as the default of ‘Agency Level’  

 
 Note: Agency level means it can contain any agency program.  Use of package program is 

an advanced feature that is not discussed further in this tutorial.  The use of package program 
is only recommended in rare cases, such as DSHS budget building. 

 
7. Give your Decision Package a Title   

  
8. Check the Open this decision package after Save. Decision package filter will be modified.   

 
9. Select Yes and then OK to the confirmation messages 
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10. Click the Recommendation Summary Text heading   
 

11. Type Recommendation Summary text in the white text box.   
The department uses a number of servers to support statewide financial systems that state 
agencies use in budget and accounting business processes.  These current servers are in excess 
of 5-years old.  Current industry standards are to replace servers…    

 
 Note: Agency Recommendation Summary Text: Brief description of the decision package, 

written in complete sentences. This text will be loaded into the OFM Budget System and be the 
starting point for the text that describes items funded in the Governor’s budget. (BDS)  
 

12. Select the Spell Check button and correct any mistakes 
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13. The remaining narrative questions are not required.  Please do not enter data into them.  
Please refer to the OFM Budget instructions for guidance on the new Decision Package 
Template and to Lesson 3 Task 3 – Creating Decision Package Document 

 
14. Select File > Save Current Tab Set  

 
15. Select Edit  > Expenditure Detail Amounts  

 
16. Select the Affected Program > Available Activity and click the > to move this into the 

Affected Programs/Subprograms/Budget Units/Activities. Do this for each Affected 
Program and Activity combination 

 010 – A005 
 010 – A012 
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17. Click ‘Save’ and ‘Yes’ 
 

 
 
 

 Note: Program level detail is only required for agencies that are appropriated at the 
program level, and recommended if your agency has more than one program.  
 

 Note: Available Subprograms and Available Budget Units can be maintained in the Other 
Budget Management Options under Titles Management. The previous box must be selected 
before the next field is enabled. 
 

 Note:  The Affected Programs/Subpgms/Budget Units/Activities tab is the easiest way to 
create column structures in the expenditure worksheets. Assigning activities through this tab 
will allow you to meet the requirement of providing maintenance level totals by activity.   
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18. Navigate to the Fund Detail tab 

 
22. Enter the Fund/Appropriation Type and hit the Tab key    

 0011 
 

19. Enter the Fund Estimates  
 

 Program 010 / A005 Program 010 / A012 
1st Fiscal 
Year 

2nd Fiscal 
Year 

1st Fiscal 
Year 

2nd Fiscal 
Year 

001-1 5,000 10,000 10,000 10,000 
 

20. Right Click on Fund 996-Z and ‘Delete Row’   
 

 
 

21. Select the Objects of Expenditure Detail tab 
 

22. Select the Objects of Expenditure Detail   
 E – Goods\Othr Svcs 

  
 

  Note:  Objects are not required in BDS for electronic release.  However, using objects in 
all steps of your budget development is recommended for additional analysis. Your Agency can 
choose to enter objects at the same level as your allotments. This will assist you in developing 
your biennial allotment control numbers once a budget is enacted. 

 
23. Right Click on Object ‘X’ and ‘Delete Row’ 

 
 Note: Object X is a placeholder only. 
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24. Enter your Object estimates 
 

 Program 010 /A005 Program 010 / A012 
1st Fiscal 
Year 

2nd Fiscal 
Year 

1st Fiscal 
Year 

2nd Fiscal 
Year 

E-Goods And Services 5,000 10,000 10,000 10,000 
 

25. Select View > Balance Funds to Objects to verify that the objects entered balance with the 
funds entered. 

 

 
 

26. Select File > Save Current Tab Set 
 

27. Select File > Add a decision package 
 

28. Add another Maintenance Level decision package and complete with the following 
information: 

 
 
Budget Period: 

 
 
Ensuing Biennium 

Version: <your initials>  <your name> Practice 
Package Program: Agency Level 
Budget Level: M2 - Inflation and Other Rate Changes 
Package Code: 8L 
Package Title: Lease Rate Adjustments 
        

Recommendation Summary Text: 
Dollars requested to provide funding to the 
Department for 2015-17 contracted lease 
increases. 

Program FY1 FY2   
020/A001 7,500 10,000   
030/A001 12,500 15,000   
050/A001 22,500 25,000   
    

 
  

RESULTS* You now have completed budget development through the maintenance level.  
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Lesson 3, Task 2 – Enter Performance Level Decision Packages 
 

Incremental expenditure changes that do not fall under the definitions of carry-forward or maintenance 
levels are considered policy or performance changes. These changes may represent revised strategies 
or substantial differences in program direction, and will include proposed program reductions. Each 
significant change to current performance must be justified in a decision package.  
This task takes you through the steps of creating the decision packages with increments entered by 
activity to meet OFM requirements.  Please refer to the OFM Budget Instructions for more guidance 
on policy level Decision Packages.  
 

1. Add a performance level decision package using the steps learned in the preceding task:  
 Budget Period – 2017-19 
 Version – <your initials> - Practice  
 Package Program – Agency Level 
 Budget Level – PL – Performance Level 
 Decision Package Code – <P1> 
 Package Title – Expand Client Training Program 

 
2. Enter and save Recommendation Summary Text using the steps learned in the                    

preceding task.   
Agency training services have been running above capacity for the past two years. We 
currently have a 6-month wait list for customers to attend systems training.  Funding is required 
in order to expand the program to address backlog...  

 
 Note:  Recommendation Summary text is required by the system for electronic release of 

your budget.   
 

3. Once the decision package opens, select Edit > Expenditure Detail Amounts  
 
4. Select the Affected Pgms/Subpgms/Budget Unit/Activities tab 
 
5. Highlight Agency Level in the Affected Programs/Activities column and the < to move out of 

the list. 
 
6. Use the combination of Available Program and Available Activity for each combination of 

program and activity with incremental adjustments in this decision package and use the > to 
move each combination into the Affected Programs/Subprograms/Budget Unit/Activities 
list.  
Program / Activity 
020/A005 
020/A013 

 
7. Click ‘Save’ and ‘Yes’ 
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8. Go to the Fund Detail tab to enter estimates by fund and program/activity combination. 
 

Fund Program 020 / Activity A005 Program 020 / Activity A013 

001-1 
1st Fiscal Year 2nd Fiscal Year 1st Fiscal Year 2nd Fiscal Year 

15,000 20,000 15,000 20,000 
 

9. Go to the Objects of Expenditure Detail tab to enter estimates by Object and 
program/activity combination. 

 
Object Program 020 / Activity A005 Program 020 / Activity A013 

A 
1st Fiscal Year 2nd Fiscal Year 1st Fiscal Year 2nd Fiscal Year 

11,000 14,600 11,000 14,600 
B 4,000 5,400 4,000 5,400 

 
10. Select View > Balance Funds to Objects to verify funds and objects are in balance. 
 
11. Go to the FTE Detail tab to enter FTE estimates by fund and program/activity combination. 
 

Fund Program 020 / Activity A005 Program 020 / Activity A013 

001-1 
1st Fiscal Year 2nd Fiscal Year 1st Fiscal Year 2nd Fiscal Year 

.4 .5 .4 .5 
 
12. Select File > Save Current Tab Set 

 
13. Select Edit > Performance Measure Increments  

 
14. Select each Activity that is supported by the Decision Package 

A005 
A013 

  Note: The list of supported activities may or may not mirror the list of activities with 
incremental estimates.   
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  Note:  When you get the screen below, this is because you have not linked performance 

measures to the Supported Activity. You will need to contact your OFM Analyst to go to the 
Activity Descriptions application and link performance measure(s) to the activity.   
 

 
 

15. Select the Performance Measure Detail tab 
 

 
 

16. The Performance Measure Detail screen lists all performance measures that support any of 
the Activities marked as supported in the Activities tab.  
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  Note:  There is a critical pre-release edit that verifies the performance measure with Usage 

Type of “Budget” has a status of “Approved” or “Under Review” and is an “Active” 
Performance Measure.  When the performance measure is in “Draft” only status or 
“Returned” only status (meaning there isn’t also an Approved performance measure) the user 
will receive a critical pre-release error when they run the report (see Lesson 4, task 5) You may 
unlink this performance measure from the Activity.  The other option would be to release the 
performance measure to OFM that is causing the error. 

 
17. Enter the estimated incremental change for the performance measures as a result of this 

decision package. 
First listed performance measure     10.00    20.00 
 

18. Click Apply to save changes 
 

19. Select View > List Decision Packages by ID  
 

20. Select Reports > OFM Reports > Performance Measure Incremental Estimates for the 
Biennial Budget   

 
  Note:  This report will provide a listing of all the incremental estimates assigned to agency 

performance measures.    
 

 
 

 
21. Print a copy of the report if desired 

Skip this step in training – a copy of the report can be found in Appendix 2. 
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Lesson 3, Task 3 – Creating Decision Package Document 
 
To ensure that your data residing in BDS is in synch with your Decision Package Word Document, run 
the BDS017 report. This report will export the following data for inclusion in your Word created 
decision package document: 
 

 Agency number and name  
 Decision Package Code/Title: 2-digit RecSum code and short, descriptive title, limited to 35 

characters. This will appear on RecSum reports  
 Budget Period: Biennium for which appropriation is requested  
 Budget Level: Maintenance level or policy/performance level RecSum code  
 Agency Recommendation Summary Text: Brief description of the decision package, written in 

complete sentences. This text will be loaded into the OFM Budget System and be the starting 
point for the text that describes items funded in the Governor’s budget.  

 Fiscal Detail: The operating expenditures by account and objects of expenditure; staffing detail 
by FTEs and revenue detail by account that agencies have entered into BDS for each decision 
package. 

The agency must then also complete the required elements of the decision package in the Word 
template: Please refer to the OFM 2017-19 Operating Budget Instructions for detailed instructions. 
 

1. Click once to highlight the necessary Decision Package 
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2. Select Reports > OFM Reports > Decision Package (or Decision Package Program Detail 

for agencies appropriated by program) 
 

 
 

3. If exporting to Word, Select Check here if you want this formatted for Word, then click OK   
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4. Select to Report Format and click View 

 

 
 

5. The report provides the following data: 

 Agency 
 Decision Package Code/Title 
 Budget Period 
 Budget Level 
 Recommendation Summary Text  
 Fiscal Detail, Object Detail, and/or Revenue Detail 
 Links to the new Decision Package Template, Budget instructions and Assigned Budget 

Analyst list 
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6. You will use the information on this report to complete the new Decision Package 
Template.  You will copy and paste into the appropriate fields.  You will also need to enter the 
next two fiscal year detail information to complete the form. 
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7. You will then need to complete the questions at the bottom of the report. 
 

 

8. Once you have copied over the information into the template you will want to save the 
template into a folder for printing and updating as necessary. 
 

9. Close the Report Tab to return to the list of Decision Packages 
 

10. Select the next decision package and repeat steps 1-9 
 

11. It is strongly recommended that you attach your Decision Package Documents to your data 
residing in BDS. Please continue to the next Task for instruction 
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Lesson 3, Task 4 – Adding an Attachment to a Decision Package 
Important things to note: 

 OFM recommends that agencies attach the final Decision Package in Word format  
 To make changes to your Decision Package Document, make the changes on your desktop, 

delete the invalid document and reattach the updated one. 
 To print attachments you will need to open the decision package attachments (Lesson 3, 

Task 5) and print them individually. 
 Attachment files are limited in size to 3MB 

1. From the List Decision Packages by ID screen, select the appropriate Decision Package  
 

2. Select Edit > Expenditure Detail Amounts 
 

3. Select Edit > Attachment, the dialog box will open, Select Add 
 

 
 

4. Select Browse 
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5. Locate the Decision Package Document and double click to select  

 
6. Enter a Description 

 
7. Select Attach and OK  

 

 
 

8. Exit out of the dialogue boxes  
 

9. From the View > List Decision Packages by ID screen, scroll to the right to view the 
Contains Attachment list 
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Lesson 3, Task 5 – Viewing an Attachment to a Decision Package 
 

1. From List Decision Packages by ID screen, double click the packet that you want to view the 
attachment. 
 

2. Select Edit > Expenditure Detail Amounts (you may also select Revenue Detail   Amounts or 
Performance Measures selections).   

 
3. Select Edit > Attachments and the Manage Attachments dialog box will open 

 
4. Select the attachment and click View 

 

 
 

5. A File Download dialog box will appear, select Open 
 

  Note: To make changes to your Decision Package Document, make the changes on your desktop, 
delete the invalid document and reattach the updated one. 
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Lesson 3, Task 6 – Update Revenue Estimates 
 
Part of the budget development process involves providing estimates to OFM on the level of revenue 
each administering agency expects to receive. This step will look at developing the maintenance level 
revenue that is not tied to a specific decision package. Revenue that is resulting from a specific 
decision package should be recorded within that decision package. The data entry steps are the same. 
 

1. Select File > Add a decision package to my base  
 

 Note: You may enter your base maintenance level revenue using this single decision 
package decision as this lesson outlines.  You would then run a report to review the resulting 
base and enter only the needed adjustment to meet expected maintenance level in this decision 
package. 

 

 
 

2. Select the Budget Period  
2017-19 

 
3. Select the Version  

<Your initials> - <Your name> Practice 
 

4. Select ‘M1 – Mandatory Caseload and Enrollment’ from the Budget Level  
 

5. Select an available decision package code from the list under View Decision Package Codes 
90 

 
6. Leave the Package Program drop down box at the default of ‘Agency Level’   
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 Note: Agency level means it can contain any agency program.  Use of package program is 
an advanced feature that is not discussed further in this tutorial.  The use of package program 
is only recommended in rare cases, such as DSHS budget building. 

 
7. Type in a Package Title for this decision package  

Maintenance Level Revenue   
  

 Note:  This title will be pre-filled with the OFM Pre-assigned title for this particular code. 
 

8. Check the Open this decision package after Save. Decision package filter will be modified.   
 

9. Click ‘Save’, and select ‘Yes’ and ‘OK’ for the following two messages   
 

  Note: Revenue only decision packages do require revenue narrative and recommendation 
summary text. Please refer to the OFM Budget Instructions for more guidance. 

 

 
 

10. Leave the Fund and Source as All, click Apply   
 

 Note: The revenue filter was developed to assist agencies that have a large number of 
revenue funds and sources (e.g., State Treasurer's Office) so that they could narrow the number 
of revenue lines displayed on the following worksheet. Using the options of All and All will be 
sufficient for most agencies. 
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11. Enter the Fund and hit Tab  

001 
 

12. Enter the four-digit major source/source combination and hit Tab  
0316 
  

 Note: You may also right click on the cell to bring up a selection dialog box.  
 

13. Repeat steps 11 and 12 for each fund / source combination needing an update 
 

14. Right click on the Fund 996 / Source 9999 and ‘Delete Row’ 
 

15. Enter estimates for each fund/source 
$30,000 each year.  

   
  Note: Enter the expected maintenance level revenue that is not tied to a specific decision 

package for each source.  For revenue that is associated with a specific decision package, 
those increments should be included in the Revenue Detail of the specific decision package(s).   
 

 
 

16. Select File > Save Current Tab Set 
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17. Select Reports > OFM Reports > Summarized Revenue by Account and Source.  Choose  

‘Agency Level (All Programs rolled up)’ and check Include Recommendation Summary 
Text  
 

18. Click OK 
 

 
 

19. Select the Report Format and View 
 

20. Exit out of the report window to return to the Revenue Detail tab 
 

 
 
 
 

 
21. Review report for accuracy   

 
  Note: OFM requires that the agencies balance between expenditure and revenue estimates 

for federal and local/private fund sources.  A pre-release edit will provide a warning if the 
expenditures for appropriation types 2 and 7 do not align with revenue major sources 03 and 
05 respectively. 
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Lesson 3, Task 7 – Working Capital Reserve 
 
The administering agency of a special revenue fund must submit a Working Capital Reserve form that 
lists the recommended ending fund balance for those accounts. Please see Section 8.4 of the OFM 
Budget Instructions for more information about Working Capital Reserve. If your agency is not 
required to submit a Working Capital Reserve Form, skip to Lesson 4.   
 

1. Select Tools > Working Capital 
 

2. Enter Funds required in the Working Capital Reserve (B9-1) submittal hit Tab   
419 

 
3. Enter estimates for the current and ensuing biennia   

 
CB Amount EB Amount 
1,000,000 1,000,000 

 
4. Select File > Save Current Tab  

 

 
 

5. Select Reports > OFM Reports > Working Capital (B9-1).  Choose ‘Agency Level (All 
programs rolled up)’.  A sample of this report can be found in Appendix 3. 
 

6. Print if desired  
Skip this step in training 

 
7. Exit the report window to return to the Working Capital tab 

 
8. Select File > Exit to BDS Menu 
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Lesson 4, Task 1 – Review Agency Activity Description/Performance Measure Target Amounts 
 
The Agency Activity Description ACT001 report is required as part of the budget submittal. This 
report can be run from Enterprise Reporting. Please refer to the OFM Budget Instructions for the 
Activity Performance Measure Target instructions and business rules.  
 

1. Once your agency Activity Descriptions and Performance Measure Target Amounts have been 
updated, select Reports > OFM Reports > Agency Activity Inventory 
 Go to ER Window provided in training 

 
2. Login to Enterprise Reporting 

 

 
 

3. Select Budget Reports > Operating Reports > Activity Inventory Reports 
 

4. Right click on the report title ACT001 
 

5.  Select Schedule 
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6. Make the following suggestions to match your version 

 Budget Period – 2017-19 
 Agency – Your agency 
 Version - <Your initials> - <Your name> Practice  

 Include Policy Level – Yes 

 
 

7. Click Schedule in the bottom right hand corner 
 

8. Wait a few moments until the report status changes from Pending to Success 
 
9. Double click on the Instance Time 
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10. Print the report 

Skip this step in training 
 
11. Logoff and close all Enterprise Reporting windows 
 
12. Review the report for activity titles, descriptions, expected results, priority, and reasonableness 

activity dollars for the version.  Also, verify the performance measure totals and determine 
adjustment needed.   
 

  Note: Once Performance Measure Target amounts are final, you will need to release this 
data to OFM. The performance measure target amounts should be released before releasing 
the agency budget.  More information regarding performance measures can be found in the 
Results through Performance Management (RPM) system user guide.  
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Lesson 4, Task 2 – Prioritizing Decision Packages 
 

1. Select Reprioritize Decision Packages 

 
 

 
2. Click to highlight a performance level decision package to prioritize and click the Top button 

 

 
 

3. Click once to highlight the Second performance level decision package and click the Move To 
button   
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4. Type ‘2’ in the is: field 
 

 
 

5. Make sure that Highlight the new priority row is unchecked 
 

6. Click OK 
 

7. Click once to highlight the Third priority decision package and click the Up and Down buttons 
as necessary to move it back into the third position  
Move your final Performance Level decision package to spot #3

 
8. Click Save 

 
  Note: You must prioritize performance level decision packages for your OFM submittal. 

BDS allows for prioritizing all decision packages of a version regardless of budget level. The 
assigned priority is not electronically submitted to OFM, but is used in reporting.  The 
Decision Package Summary prints a list of performance level decision packages in priority 
order. You may choose to prioritize maintenance level decision packages if you will be printing 
the Working Recommendation Summary in priority order.   The OFM Recommendation 
Summary report will print in budget level, decision package code order. Simply leave un-
prioritized decision packages (for current biennium and carry-forward level) at the bottom of 
the priority list. Although BDS will assign a low-level priority number, this number will not be 
used in BDS or OFM internal budget systems (WinSum). 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Page 60 of 86 
 

Lesson 4, Task 3 – Revising Decision Package Titles 
 

1. Select the Agency Decision Package Identification tab 
 

 
 

2. Find a decision package code for any decision package requiring a Title change   
 

3. Change the decision package Title 
Expand Client Training Opportunity 
 

  Note: Changing the decision package title on the Agency Decision Package Identification 
tab will change the title for all decision packages with this code for the indicated budget 
period. Only Budget Operations users may change a decision package title. 

 
4. Click Save 
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Lesson 4, Task 4 – Decision Package Status 
 

1. Select the Decision Package Control tab 
 
2. Use the bottom scroll bar to move to the far left 

 
3. Click once to highlight the first maintenance level decision package 

 
4. Select the Status 

Final 
 

  Note: The status you choose here will print on the actual decision package.  You may 
choose the <blank> option to not have any stamp on the decision package.   

 

     
 

5. Repeat steps for each maintenance and performance level decision package 
 

6. Mark all the current biennium and carry-forward level Decision Packages ‘Locked’   
 

  Note: It is optional to change the status for current biennium and carry-forward level 
decision packages since they are not printed for the budget submittal. 

 
7. Click Save
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Lesson 4, Task 5 – Run a Pre-Release Edit Report 
 
BDS has a Pre-Release Edit Report that allows users to verify that data in BDS meets all electronic 
release requirements, as well as warnings on various business rules.  This report should be ran prior to 
printing copies of the OFM submittal reports. This report can and should be run early and often in your 
budget development to ensure no last minute surprises on release day. Appendix 1 will cover the 
various error messages and their respective remedies. Warnings are errors that may raise flags with 
your OFM budget analyst, but will not prevent you from releasing your data. Critical errors must be 
resolved before you will be able to release your data. 

 
1. Select Verify data to be released to OFM > BDS Budget Data 
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2. Select the Budget Period, Budget Type, and Version  
      2017-19 

Regular 
<Your Initials> - <Your Name> Practice 

 
2. Select ‘ALL’ for Package Program and Decision Package 

 
3. Click OK   

 
 

4. Select the Report Format and View 
 

5. Print the report if desired 
Skip this step in training   

 
6. Review the report and determine if any items should be addressed then click Return 

 
 Note: Critical items MUST be corrected in order to electronically release data.  Warnings 

indicate that there is something that might not be consistent with business rules, but the 
electronic release will not be prohibited. 
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7. Review each warning error to determine if further action should be taken. 
 

8. Re-run the Pre-Release Edit report to verify corrections. Please see Appendix 1 for Common 
Submittal Errors and their Remedies.  
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Lesson 5, Task 1 – Release Data to OFM 
 
Once you pass all pre-release edits you are ready to submit your version to OFM. You must have 
security to release BDS data to complete this step. The OFM Budget Division reviews your released 
BDS data through their internal system WinSum.  Security for releasing data is granted separately from 
the BDS system.  If you do not have an icon for Release Data to OFM on the BPS Main Menu, you 
do not have security to release data.  Run an Agency Access report in Enterprise Reporting to 
determine who does have access for your agency. 
 

1. Click on the Release Data to OFM icon from the BPS Main Menu.   
 

 
 

Refer to the “BDS Release Quick Reference Guide” located in the BPS Help Library at 
https://budgetlogon.ofm.wa.gov/library/BDSRel.pdf for instructions on releasing data to OFM. 
 

WARNING – If practicing at your agency, do not complete this step.  This will 
release data to OFM. 
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Lesson 6, Task 1 – Create your Enacted Budget Version  
 
What is the Enacted Recast?  
When a new biennial or first supplemental budget is enacted, agencies must update their estimated 
costs of agency activities to reflect the new budget. This budget recast becomes the foundation for the 
next budget. Agencies enter their whole budget in terms of fund source and FTEs by Fiscal Year and 
activities.  This process eliminates having to detail CB, CL and ML decision packages by activity.   
 
Why would I want to do an Enacted Recast? 
After your Biennial Budget submittal goes through the legislative process, and becomes enacted, each 
agency is required to adjust their fund sources and FTEs to reflect accurate activity distribution. Once 
completed, it needs to be submitted to OFM and approved by your agency’s OFM Budget Analyst; this 
information is then used as the basis to build the next budget.  
 
What are the requirements for an Enacted Recast?  
It is required that an agency’s total enacted budget be spread by activity.  The following steps will 
show how to create a new version, how to select activities, how to enter recast dollars and FTEs into 
BDS, and how to run a report. NOTE: Allocations between programs and activities should happen 
prior to beginning data entry.   
 
Agencies enter the bottom line dollars by account and activity for their entire budget in one decision 
package.  Knowing the activity breakout by decision package is not required.  You need to know your 
total activity breakouts by program/subprogram/budget unit and activity before beginning this task. 
 

1. From the BDS Menu select:  
 Other Budget Management Options > Version Management > Add/Update Version.   
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2. Select the Budget Period   
 2017-19 

 
3. In the empty row enter any two-digit code in the Version cell (numbers and/or letters in any 

order) to distinguish this version then hit the Tab key.   
 <Your initials> 

 Note: Version Coding is at the agencies discretion; the same coding structure can be used 
across bienniums. 
 

4. Assign a Title to your version and hit the Tab key.   
 <Your Name> Chosen Title 

 
Select ‘Enacted’ from the list of Budget Sources 
  

5. Select ‘Regular’ from the list of Budget Types and hit the Tab key.  You should now see the 
version you just added in blue font 
 

 Note: You will choose ‘Regular’ Budget Type for the Biennial Budget. Select First Year 
Supplemental or Second Year Supplemental for your Supplemental Budget requests. 
 

6. Hit the Save button to save the Version 
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Lesson 6, Task 2 – Create the Bottom Line Recast 
             

1. Select File > Add a decision package  
 

 
2. Enter the following decision package information: 

 Budget Period – 2017-19 
 Version - <your initials> - <your name> Chosen Title, or the version you just created 
 Budget Level – PL – Performance Level 
 Decision Package Code – 9Z - Recast to Activity 
 Package Program – Agency Level 
 Package Title – Recast to Activity (cannot be changed) 
 Package Long Title – Recast to Activity (cannot be changed) 
 Open this decision package after Save… - Check the box  

 
  Note:  Package Program may be used to develop a separate recast for each agency 

program.  In this case use Package Program to determine the program for recast, and repeat 
this Step for each program. 
 

22. Click ‘Save’, and select ‘Yes’ and ‘OK’ for the following two messages   
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3. Once the decision package opens, select Edit > Expenditure Detail Amounts  

 
  Note:  Narrative is not required for the Recast decision package. 

 
23. Click on the Affected Pgms/Subpgms/Budget Unit/Activities tab  

 
24. Double click on Agency Level in Affected Programs/Subprograms/Budget Units/Activities 

list to move it out of the Affected Programs/Subprograms/Budget Units/Activities 
 

 
 

25. Select the Affected Program > Available Activity and click the > to move this into the 
Affected Programs/Subprograms/Budget Units/Activities. Do this for each Affected 
Program and Activity combination 



Page 72 of 86 
 

 
 

26. Click ‘Save’ and ‘Yes’ 
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4. Select the Fund Detail tab 
 

5. Enter the Fund/Appropriation Type and hit the Tab key    
 

6. Right Click on Fund 996-Z and ‘Delete Row’ 
 
7. Select View > Freeze Key Columns to view the funds as you use this BDS worksheet. 

 
8. Input the dollars into the column for each combination of Program, Subprogram, Budget Unit 

and Activity.   
 

 
 

9. Input the FTEs in the FTE Detail grid  
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10. Select File > Save Current Tab Set  

 

 
 

11. Run the ACT001 report to verify.  Select Reports > OFM Reports > Agency Activity 
Inventory.  This will take you to the Enterprise Reporting system to run the Activity Inventory 
report for reviewing your activities. See Lesson 4, Task 1 for instructions on how to run an 
ACT001 report. 
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Lesson 6, Task 3 – Verify Enacted Version 
 
Now that your decision package by activity reflects the Enacted Budget you will want to verify that 
this is accurate and run a pre-release edit report to see if BDS finds any errors in the version. 
 

1. Select Reports > Working Reports > Maintenance Level Totals for Activity Recast  .   

 Note: Although the menu bar option reads that the report is for Maintenance Level, the 
actual report is looking at all dollars and FTEs through Performance Level. 

 
 

2. Verify that the report indicates no balances.   

 Note: A zero balance indicates that all dollars and FTEs are allocated to activities.   

 
  

 
3. If there are dollars or FTEs in the report you will be required to adjust the version until all 

dollars and FTEs are allocated to activities. You know this is true when the report lists all 
zeros. 
 

4. Verify that the columns in each decision package have an Activity identified.  When you find a 
column that does not meet this condition you will need to add a new column with activity using 
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the Affected Pgms/Subpgms/Budget Units/Activities tab, reenter the amounts into the 
activity column and delete the original column. 

 
5. Click Close  

 
6. Select File > Exit to BDS Menu  

 
7. Select Verify Data to be Released to OFM > BDS Budget Data. See Lesson 5, Task 1 for 

instructions on how to release data to OFM. 
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Funds Invalid Funds: 239; 406; 427; 429; 996 (except for 

FTEs); 999  
 

Critical 

Appropriation Type Invalid appropriation types: 3, 4, 9 
 

Critical 

Decision Package 
Code/Title 

Numeric package codes not allowed for ML and PL 
level packages (except DSHS and OFM assigned 
codes) 
OFM assigned codes will have OFM reserved title. 
 

Warning 

Narrative (Agency Level) Recommendation Summary Text required at the 
agency level (exception follows).  
 

Critical 

Narrative (Program Level) Recommendation Summary Text is required at the 
program level for the following agencies: 
DSHS, DOT 
 

Critical 

Narrative (all other text) Users will receive a warning if not all of the categories 
contain text.  OFM will require that these categories be 
addressed in the printed decision package. 
 

Warning 

Narrative (exceptions) The following decision packages do not require 
narrative: 
Revenue only decision packages 
Codes 9C, 90, 91, 92, 98, 99, 9D, 9I, 9Z 
 

No 
message 

FTEs The following agencies must have transportation FTEs 
identified by a transportation fund: 
DOL, WSP 
 

No 
message 

Decision Package Titles Only one title per decision package is allowed per 
biennium in both the OFM system (WinSum) and BDS. 
A critical error does not allow release of a decision 
package where a code has different titles in each 
system. 
 

Critical 

Maintenance Level Total by 
Activity 

The total maintenance level total budget must match 
the activity totals at maintenance level.  
 

Critical 

Performance Level Decision 
Packages by Activity 

Performance level decision packages must provide 
activity information for each increment.  
 

Critical 

M2-9Z Recast to Activity 
decision package  

Decision Package M2-9Z Recast to Activity must have 
a net balance of zero.  
 

Critical 
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Activities without estimates Activity XXX that do not have incremental estimates 

tied (or maintenance level cumulative) should not be 
sent to OFM.   
 

Warning  

Activities without performance 
measures or expected results 

Activity XX – TITLE does not have performance 
measures or expected results identified.  Please 
update the activity description to include these 
items.  Note:  When using performance measure, 
the performance measure must be an “Active” 
Performance Measure and the Usage Type must be 
“Budget” in the Performance Measure Management 
System.   
 

Critical  

9Z for Regular Budget 9Z Recast to Activity decision package must be 
budget level M2 for regular budget.  
 

Critical 

Carry-forward Level check Fund & FTE data will be compared to OFM as a 
total for the agency for agencies that submit at the 
agency level.  Fund & FTE data will be compared to 
OFM as a total for the agency/program for the 
agencies that submit at the program level. 
(Subprogram level for DSHS JR, MH and DD.)  DOL 
and WSP will be compared at the agency total for all 
funds.   
 

Critical  

Federal Funds Match Total estimates expenditures for Federal Dollars, 
Fund/AT 001-2, of $1,800,000 has a variance from 
the estimated revenues in Fund 001, Major Source 
03 Federal of $500,000 for a difference of -
$1,300,000.  Generally, estimated expenditures and 
revenues must net to zero at the statewide level for 
federal funds.  
 

Warning 

Private/Local Match Total estimated expenditures for Private/Local 
dollars, Fund/AT 001-7, of $1,800,000 has a 
variance from the estimated revenues in Fund 001, 
Major Source 05 Federal of $500,000 for a 
difference of -$1,300,000.  Generally, estimated 
expenditures and revenues must net to zero at the 
statewide level for federal funds.  
 

Warning 

Special Major Source/Source Major Source 04, Source 01 is not a valid revenue 
source for your agency.   
 

Warning 

Performance Measures does 
not exist with a status of 
Approved or Under Review or 
is not an active performance 
measure 

Performance Measure XXX has not been released 
to OFM.  Performance Measures that are linked to 
Activities in this version, with Usage Type of 
“Budget” must be active performance measures and 
must be released to OFM prior to releasing the BDS 
version.  Alternatively you may unlink this 
performance measure from the Activity. 
 

Critical 

OFM Activities OFM has activities that begin with ZZ and are for 
their use only. 

Critical 
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Critical Errors (must be fixed before data will release to OFM) 
 
Recommendation Summary Text required at the Agency Level. 
 
Most agencies are required to submit Recommendation Summary text at the agency level.  You must 
have entered narrative on the Agency Level tab in the Decision Package narrative tab set.  If you built 
your decision package at a program level for Package Program, your narrative was entered at that 
program level.  You must save the decision package as agency level and enter agency level text. 
Use the Save As feature to copy the decision package to a new package program. 

o Delete the original decision package. See below: 
 

 Select Re-prioritize my agency’s decision packages 

 

 Select Decision Package Control 
 Select the Decision Package you are trying to copy 
 Select File 

 



Page 80 of 86 
 

 Select Save As 

 
 Select your new Budget Level, Package Program and/or Decision Package Code, Save 

Note: You can use the same DP as you are trying to copy from by selecting Used for this Version 

 
 Click Yes, OK and exit the box 
 Delete  the Decision Package that you do not want 
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Fund Detail data is not at the program level. 
 Your agency is required to submit data at the program level yet no program has been 

identified with the data in this decision package. 
o Use Affected Programs to change the data so it is recorded at the program level.  
o Delete all agency level data to ensure your decision package is not erroneously 

inflated. 
 

Fund code ‘XXX’, used in the Fund (FTE or Revenue) Detail grid, is not valid.  
 The listed fund in this decision package is not valid for the current budget period.  

 
Major Source Code ‘99’ (and/or) Source Code ‘99’, used in the Revenue Detail grid, is not 
valid. 

 Revenue for this decision package has been recorded using the default code(s) of Major 
Source 99 and/or Source Code 99. 
 Go to the Revenue section of the decision package console and add revenue to the 

Major Source/Source code.  Delete the revenue row for Major Source 99 and/or 
Source Code 99. 

 
 
Warnings (Does not conform to OFM recommendations, data release NOT prohibited)  
 

Decision package must be linked to at least one goal. 
 Maintenance Level decision packages must be linked to a goal.  Performance measure 

decision packages must be linked to a goal that has active performance measures.  
o Go to the Performance Measure section of the decision package console and check 

to identify goals that the decision package supports. 
 

Decision Package id cannot be numeric. 
 Decision Package Ids should not be numeric unless approved by OFM in advanced. 

o Use the Save As feature, described above, to copy the decision package to a new 
decision package ID.  

o Delete the original decision package.  
 

No Narrative for: (Package description)(Strategic plan)(Reason for change)(Client 
impact)(Other program impact)(Capital Relationship)(Required 
changes)(Alternatives)(Future impact)(One time ongoing)(Non funding 
impact)(Expenditure Calculations) 

 Indicates that narrative categories were omitted in the Narrative section of the decision 
package console.  OFM requires all categories be addressed in the final printed decision 
package. 
o Go to the Narrative section of the decision package console and add narrative for 

each category.  
 

Decision package has no data. 
 The decision package has no fund or FTE data.  The decision package ID and title will 

be transmitted to OFM. 
o Go to the Expenditure Detail Amounts section of the decision package console to 

enter expenditure estimates.  
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